Выбор версии РНР для битрикс

Выбор версии РНР для битрикс

02.01.2020

При выборе версии РНР для битрикс нужно учитывать ряд моментов:

1) Совместимость вашей версии Битрикс с заявленными версиями РНР для главного модуля, на данный момент рекомендуемая версия PHP 7.2

для v20.0.200 2019-11-28 - заявлено, что улучшена совместимость с PHP 7.4.

для v19.0.400 2019-08-22 - заявлено, что улучшена совместимость с php 7.3.

с версии v18.5.0 апрель 2019 - улучшена поддержка PHP 7.3.

2) Совместимость модулей маркетплейс

Далеко не факт, что свежие версии РНР своевременно поддерживаются, особенно это касается бесплатных модулей.


Ещё статьи:

20.09.2021 Разговор с рекрутером в 2021. Мидл это младший специалист и на удалёнку не ниже сеньёра
Рекрутер: В принципе ок, но обычно младших специалистов мы в офис берем). Что скажете?
П.С. Мда, интересно оказывается, что мидл это младший специалист,... ID: 320

01.12.2020 Свершилось, битрикс перестал поддерживать mbstring.func_overload
Теперь для обновления на версию v20.100.0 требуется удаление опции mbstring.func_overload. Эта опция более не требуется и не поддерживается платформой... ID: 313

13.08.2020 Получить id элемента привязки к пользователю битрикс
Получить id элемента, который добавлен в свойство привязки к пользователю битрикс ID: 250

Новые статьи в блоге:

06.04.2022 Своё АПИ на сайте битрикс без модуля
Искал куда компонент спрятали и нашёл такую реализацию мини АПИ без модуля. ID: 333

18.03.2022 Получение минимальной цены и сохранение в свойство
Пополнение - пример события OnPriceUpdate для получение минимальной цены и сохранения в свойство инфоблока. ID: 332

12.02.2022 Проверка групп пользователя и исключение разделов
Пример события для проверки групп пользователя с целью исключить разделы из общего доступа ID: 331

Возврат к списку

© 2015-2022 Web админ
Связаться по WhatsApp